Pages

Friday, December 28, 2012

Cisco AP Configuration


As we use WLAN as solution . Many times we will end up with configuring diffrent kind of vendors APs.
In this part i will try to cover some of the very basic info for Cisco AP configiguration. 
Cisco Configuraion guide will cover all aspects but it is very huge. So covering here some of important steps only.

1. Connecting the AP

Cisco AP we can connect in primarly through Serial, Telnet , http and https.

For connecting to serial baud rate we need to use 9600 and all others are default
default user/password :Cisco/Cisco

2. Assigning the host name


ap>enable
Password:xxxxxxx
ap#config terminal
Enter configuration commands, one per line. End with CTRL-Z.
ap(config)#hostname my_ap
my_ap(config)#end
my_ap#


3.Assigning IP address

 For assigning IP address first check IP address

AP# show ip interface brief

Interface     IP-Address     OK?  Method  Status                  Protocol
BVI           10.108.00.5    YES  manual   up                      up      
dot11radio0   unassigned     YES  unset   administratively down   down    
dot11radio1   unassigned     YES  unset   administratively down   down    
    

Once we know the current ip address then we can assign IP address

configure terminal
interface bvi1
ip address <IP xxx.xxx.xxx.xxx>  <mask xxx.xxx.xxx.xxx>
end

4. Creating open Profile 

conf t
dot11 ssid <ssid name>
authentication open 
guest-mode
inter d0/d1
ssid <ssid name>
no shut
end


5. configuring the radius server on AP along with secure profile

config terminal
aaa new-model
radius-server host <Radius_server_IP> auth-port 1812 acct-port 1813 key <secret key in the radius server>
aaa group server radius  rad_eap
server <Radius_server_IP> auth-port 1812 acct-port 1813
aaa authentication login eap_methods group rad_eap

dot11 ssid <ssid name>
authentication open eap eap_methods
authentication network-eap eap_methods
authentication key-management wpa
inter d0/d1
encryption mode ciphers <aes/tkip>
ssid <ssid name>
no shut
end


5. Creating local DHCP server on AP 

configure terminal
ip dhcp excluded-address low_address [ high_address]
ip dhcp <pool pool_name>
network subnet_number [ mask | prefix-length ]
lease { days [ hours ] [ minutes ] |infinite }
end

example:

AP# configure terminal
AP(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.20
AP(config)# ip dhcp pool test
AP(dhcp-config)# network 172.16.1.0 255.255.255.0
AP(dhcp-config)# lease 10
AP(dhcp-config)# default-router 172.16.1.1
AP(dhcp-config)# end


6. Creating local radius server

configure terminal
aaa new-model
radius-server local
nas <ip-address_of_AP> key <shared-key>
user <username>  password <password>
end

example:

AP# configure terminal
AP(config)# radius-server local
AP(config-radsrv)# nas 10.91.6.159 key 110337
AP(config-radsrv)# nas 10.91.6.162 key 110337
AP(config-radsrv)# nas 10.91.6.181 key 110337
AP(config-radsrv)# user jsmith password twain74 


7. Setting the clock on the AP

AP# clock set 13:32:00 23 July 2001

8.Configuring the data rates on the AP.

configure terminal
interface dot11radio { 0 | 1 }
speed
802.11b, 2.4-GHz radio:
{[1.0] [11.0] [2.0] [5.5] [basic-1.0] [basic-11.0] [basic-2.0] [basic-5.5] | range | throughput}
802.11g, 2.4-GHz radio:
{[1.0] [2.0] [5.5] [6.0] [9.0] [11.0] [12.0] [18.0] [24.0] [36.0] [48.0] [54.0] [basic-1.0] [basic-2.0] [basic-5.5] [basic-6.0] [basic-9.0] [basic-11.0] [basic-12.0] [basic-18.0] [basic-24.0] [basic-36.0] [basic-48.0] [basic-54.0] | range |
throughput [ofdm] | default }
802.11a 5-GHz radio:
{[6.0] [9.0] [12.0] [18.0] [24.0] [36.0] [48.0] [54.0] [basic-6.0] [basic-9.0] [basic-12.0] [basic-18.0] [basic-24.0] [basic-36.0] [basic-48.0] [basic-54.0] |
range | throughput | default }
802.11n 2.4-GHz radio:
{[1.0] [11.0] [12.0] [18.0] [2.0] [24.0] [36.0] [48.0] [5.5] [54.0] [6.0] [9.0] [basic-1.0] [basic-11.0] [basic-12.0] [basic-18.0] [basic-24.0] [basic-36.0] [basic-48.0] [basic-5.5] [basic-54.0] [basic-6.0] [basic-9.0] [default] [m0-7] [m0.] [m1.] [m10.] [m11.] [m12.] [m13.] [m14.] [m15.] [m2.] [m3.] [m4.] [m5.] [m6.] [m7.] [m8-15] [m8.] [m9.] [ofdm] [only-ofdm] | range | throughput }
802.11n 5-GHz radio:
{[12.0] [18.0] [24.0] [36.0] [48.0] [54.0] [6.0] [9.0] [basic-12.0] [basic-18.0] [basic-24.0] [basic-36.0] [basic-48.0] [basic-54.0] [basic-6.0] [basic-9.0] [default] [m0-7] [m0.] [m1.] [m10.] [m11.] [m12.] [m13.] [m14.] [m15.] [m2.] [m3.] [m4.] [m5.] [m6.] [m7.] [m8-15] [m8.] [m9.] | range | throughput }
end

ex: 
conf t
int d0
speed basic-1.0 54.0
end

9.Configuring the  Channel on the AP.

configure terminal
interface dot11radio { 0 | 1 }
channel
{frequency | least-congested | width [20 | 40-above | 40-below] | dfs }
end

example:

conf t
int d0
channel 36
end


10.Configuring the Power of radio  on the AP.

configure terminal
interface dot11radio { 0 | 1 }
power local
These options are available for the 802.11b, 2.4-GHz radio (in mW):
{ 1 | 5 | 20 | 30 | 50 | 100 | maximum }
These options are available for the 5-GHz radio (in mW):
{ 5 | 10 | 20 | 40 | maximum }
These options are available for the 802.11a, 5-GHz radio (in dBm):
{-1 | 2 | 5 | 8 | 11 | 14 | 15 | 17 | maximum }
These options are available for the AIR-RM21A 5-GHz radio (in dBm):
{ -1 | 2 | 5 | 8 | 11 | 14 | 16 | 17 | 20 | maximum }
These options are available for the 2.4-GHz 802.11n radio (in dBM):
{ -1 | 2 | 5 | 8 | 11 | 14 | 17 | 20| 23 | maximum }
end

example:

conf t
int d0
power local 17
end

11.Configuring the Power of radio  on the AP.

configure terminal
interface dot11radio { 0 | 1 }
world-mode
dot11d country_code code
{ both | indoor | outdoor } world-mode roaming | legacy
end

example:

conf t
int d0
world-mode dot11d country_code US both
end

12.Disabling Short Radio Preamble

configure terminal
interface dot11radio 0
no preamble-short
end

Enabling Short Radio Preamble

configure terminal
interface dot11radio 0
no preamble-short
end

13.selecting the Transmit and Receive Antennas

configure terminal
interface dot11radio { 0 | 1 }
antenna receive
{diversity | left | middle | right}
antenna transmit
{diversity | left | right}
end

example:
configure terminal
interface dot11radio  0
antenna receive left
antenna transmit left
end

14. enabling and disabling the radios

configure terminal
interface dot11radio  0/1
shut
no shut
end